Order By

Options

Why does the order of elements change every time we run an API or an ETL? If I put a select column tile on an ETL, immediately followed by an output, I would expect the output fields to be in the order of the select column tile.

I'm currently working on a complex aging flow and running the flow makes the dataset wonky and I find myself spending so much time mapping fields because I have to keep re-ordering the dataset.

** Was this post helpful? Click Agree or Like below. **
** Did this solve your problem? Accept it as a solution! **

Tagged:

Comments

  • MarkSnodgrass
    Options

    @ArborRose you can actually set the order of the output dataset without modifying the ETL and adding a select columns tile. In the Data Center, click on your dataset and then click on Data and then the Schema icon that is on the right. Hover over the left side of the page and you can click and drag any column to the order that you want.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • ArborRose
    Options

    @MarkSnodgrass - that doesn't hold the order. As I mentioned, when the ETL is modified or an API reruns every morning the dataset order changes.

    ** Was this post helpful? Click Agree or Like below. **
    ** Did this solve your problem? Accept it as a solution! **

  • ArborRose
    Options

    @Admin - this was posted as a discussion, not a question. And yes, I would like to know if anyone has a way to "save" the order. I am still working on this AR dataset and have to reorder all the fields (the way Mark describes) every time I update my ETL.

    ** Was this post helpful? Click Agree or Like below. **
    ** Did this solve your problem? Accept it as a solution! **