ETL and Beastmode

Options
Zel
Zel Member

Hello, hope someone can help me.

=========

I have a card level beast mode and filter:

Company Name NOT IN "AAA"

Destination - AAA Filter NOT IN "Exclude"

=========Here's the beast mode for Destination - AAA Filter:
CASE
WHEN Destination like '%AAA%' THEN 'include'
WHEN Destination like '%Tipp City%' THEN 'include'

WHEN Destination like '%Lansing%' THEN 'include'

WHEN Destination like '%Newport, MI%' THEN 'include'

WHEN Destination like '%Pleasant Prairie%' THEN 'include'

ELSE 'Exclude'
END

========

I created a draft ETL with the same beast mode and filter logic above. For context, I needed to create an ETL to produce a different card output that consists these mentioned conditions, but let's just stick to the above filters and draft ETL (replicate) since that's the part where I'm getting an issue.

I'm getting a different output from the "Card Level Beastmode Filters" that I created versus the ETL results with the same logic as above.

Card Level Beast Mode and Filter: 898 rows

ETL: 16 rows

Dataset and date periods used are the same

This is the draft ETL created to check if the output is the same with the card level output above. Unfortunately, I'm getting a different output, ETL is showing lesser rows than the card level output.

Any idea causing this and possible solution for the ETL?

Tagged:

Answers

  • GrantSmith
    GrantSmith Coach
    edited July 10
    Options

    Your logic is a bit different between the two

    On your card filter you are checking for the explicit value of AAA but in your ETL you’re checking Contains AAA so if there are other records, which are not explicitly AAA it will be included in the card BAAA works be included in the card but not your ETL. You need to either change your card to a contains filter or change your ETL to be an explicit equals to filter.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • Zel
    Zel Member
    Options

    Hi @GrantSmith. I already tried using "not equal" in my ETL, but still showing the same output.