OneDrive for Business Connector Not Uploading Recent File Version

Options

I updated an excel spreadsheet this morning that is set to be uploaded through the Microsoft OneDrive for Business data connector. The initial upload worked without issue. However, it's been 6 hours since I updated the file and everything I click "Run Now" for the dataset, it pulls the original version of the file.

I have already verified that the file in OneDrive shows my changes when I open it in a web client.

I also tried making a new identical data connector and it pulled the old data as well.

Best Answer

Answers

  • david_cunningham
    Options

    I can't speak specifically to this connector, but in the past when using some of the Microsoft connectors, I've had to make sure to be out of the file for it to update properly.

    You may have already done this, but linking the documentation below so you can review to make sure that you have everything properly configured.

    https://domo-support.domo.com/s/article/360043436753?language=en_US

    In particular, take a look at permissions/access settings.

    David Cunningham

    ** Was this post helpful? Click Agree 😀, Like 👍️, or Awesome ❤️ below **
    ** Did this solve your problem? Accept it as a solution! ✔️**

  • kyle_l_smith
    Options

    Thank you. I did have the file open in my local Excel client. The changes had been saved and uploaded to OneDrive for Business, but the file was open. Closing the client has not helped the issue.

    I also tried adding an x to a cell, saving and uploading, then deleted the x and saving and uploading. Made sure the file is not open on the web or locally.

    As far as permissions, I created the file and have full access to its location. I've also followed the attached documentation for setting up the Azure Enterprise App so I know the permissions are all in line. I needed for those to be set up to upload the original version of the file.

    I verified in Azure that the app doesn't have any issues or expired secrets. I set it all up on Friday so it's all pretty fresh.

  • ColemenWilson
    Answer ✓
    Options

    If I solved your problem, please select "yes" above