Google (sheets) connect - This app is blocked

Options

I'm receiving the following error when trying to connect Domo to Google Sheets:

This app is blocked

This app tried to access sensitive info in your Google Account. To keep your account safe, Google blocked this access.

I read only this has to be fixed by the developer as it doesn't meet Google's security standards.
Is this correct or is there another way around this?

Best Answer

  • EvilGenius
    EvilGenius Member
    edited June 9 Answer ✓
    Options

    I tried the steps below and managed to get it working. Login to your Google admin account https://admin.google.com/u/5/ac/owl/list?tab=apps

    Hover on the row Domo and you will see the "Change access" will appear. Click on Change access.

    In the next screen , select the all users option

    Choose Trusted and click Next

    Review the changes and Click on Change Access

    Refresh your Domo browser and Try to connect to Google sheet again

Answers

  • david_cunningham
    Options

    Are you using a Google workspace company account or a personal account? I haven't run into this issue with the Google Sheets Connector before.

    David Cunningham

    ** Was this post helpful? Click Agree 😀, Like 👍️, or Awesome ❤️ below **
    ** Did this solve your problem? Accept it as a solution! ✔️**

  • GrantSmith
    Options

    Have you tried re-authenticating the account to approve the scopes necessary for the connection?

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • user046467
    user046467 Member
    edited June 6
    Options

    @david_cunningham

    Workspace company account.

    I haven't run into it either as I connected 2 accounts succesfully before.
    We also haven't changed anything related to privacy or security settings.

    It might be a new issue as I saw another user here with a similar issue :

    @GrantSmith

    How do you mean? I'm adding a new account to the Google Sheets connector so I can't re-authenticate as I haven't connected this account before. The other accounts I've connected before within the same workspace are working as intended

  • SimonKing
    SimonKing Member
    Options

    When I try to set up the connector, it takes me to the google login page and when I try to authenticate my Google company account, which is an admin, I get this message.

  • SimonKing
    SimonKing Member
    edited June 6
    Options

    In google I have allowed 'less secure apps' (changed weeks ago) but still have the issue

  • EvilGenius
    EvilGenius Member
    edited June 9 Answer ✓
    Options

    I tried the steps below and managed to get it working. Login to your Google admin account https://admin.google.com/u/5/ac/owl/list?tab=apps

    Hover on the row Domo and you will see the "Change access" will appear. Click on Change access.

    In the next screen , select the all users option

    Choose Trusted and click Next

    Review the changes and Click on Change Access

    Refresh your Domo browser and Try to connect to Google sheet again

  • SimonKing
    Options

    I have done that and the app looks good but still doesnt work.

    One thing I have noticed is that the requested services appears to be blank

    Whereas yours shows Drive and google Sign in. Is there some way to add this or delete and start again?