Errors caused by Timezone, Where can I adjust it?

Options

I found the dataset in DOMO is different from the raw data in google sheet for DATETIME field probably due to time zone different. Where can I adjust it?

thank you so much.

Tagged:

Best Answer

  • GrantSmith
    GrantSmith Coach
    Answer ✓
    Options

    When Domo imports data, it's assumed to be within UTC, then when the data is visualized, it's translated to the timezone configured in your instance company settings. You can leverage an ETL with a formula tile and a CONVERT_TZ function to change the timezone of a timestamp if necessary.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**

Answers

  • david_cunningham
    edited May 27
    Options

    @Lu_zhang

    There are 2 types of timezone settings in Domo.

    Anyone can define their personal time zone in Domo to determine when they receive alerts, notifications, and scheduled reports. Admin-level users can define a company time zone for the entire instance to standardize how visualizations display.

    If there is a company defined timezone, Domo assumes that all data loaded in is in UTC.

    To set the company time zone, you must be an Admin or have a custom role with the following grant enabled:

    (Admin-level) Manage All Company Settings — This grant permits the user to manage company metadata, authentication rules, security, publishing, and more.

    Go to Admin>Company Settings>Company Overview>Formatting>Time Zone.

    Since Domo expects that all input DATETIME values are in UTC, note the following:

    • DATETIME values are not converted to UTC during import from self-managed DataSets (such as Excel, Box, Google Sheets, or file upload). Data in these sources must be stored in UTC before import.

    David Cunningham

    ** Was this post helpful? Click Agree 😀, Like 👍️, or Awesome ❤️ below **
    ** Did this solve your problem? Accept it as a solution! ✔️**

  • GrantSmith
    GrantSmith Coach
    Answer ✓
    Options

    When Domo imports data, it's assumed to be within UTC, then when the data is visualized, it's translated to the timezone configured in your instance company settings. You can leverage an ETL with a formula tile and a CONVERT_TZ function to change the timezone of a timestamp if necessary.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • Lu_zhang
    Lu_zhang Member
    Options

    I think It probably is the point. Can you pls teach me on how to write CONVERT_TZ function? My raw data's timezone is UTC + 8:00(Beijing time), My company timezone in DOMO is UTC - 4:00(New York time).

    @GrantSmith thank you so much

  • GrantSmith
    Options

    CONVERT_TZ

    CONVERT_TZ() converts the datetime value dt to a new moment in time such that the original value''s wall-clock time when rendered in from_tz matches the new value''s wall-clock time when rendered in to_tz.

    CONVERT_TZ(dt,from_tz,to_tz)

    https://domo-support.domo.com/s/article/360044289573?language=en_US

    Alternatively you could set the timezone of your data in the dataset configuration when you're importing it into Magic ETL

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**