Issue with MagicETl Filter Tile

Options
Strongreece
Strongreece Domo Employee

Hello there,

I am trying to filter a dataset in MagicETL using the Filter Tile, and have confirmed that the data I wish to filter by exists in the dataset 'Cadence name' by 'Outbound - Short'. Yet everytime I try this by running a preview, I get the response "No rows matched your criteria".

Tagged:

Best Answer

  • MichelleH
    MichelleH Coach
    Answer ✓
    Options

    @Strongreece The issue appears to be coming from the % symbols in your filter. These can serve as wildcards when using the LIKE operator, but when using the = operator it looks for exact matches. For exact matches, your filter should be `Cadence name` = 'Outbound - Short'. If you want to return all rows that contain that text then you want to use `Cadence name` LIKE '%Outbound - Short%'

Answers

  • david_cunningham
    Options

    there’s 658 out of almost 3.5 million rows that meet that criteria. Preview doesn’t process all rows, just the first 10k up to 400k. One way to test if this filter is working as expected is to attach an output dataset (“test filter”) and execute the dataflow. If the output matches, you know you are good to go.

    David Cunningham

    ** Was this post helpful? Click Agree 😀, Like 👍️, or Awesome ❤️ below **
    ** Did this solve your problem? Accept it as a solution! ✔️**

  • MichelleH
    MichelleH Coach
    Answer ✓
    Options

    @Strongreece The issue appears to be coming from the % symbols in your filter. These can serve as wildcards when using the LIKE operator, but when using the = operator it looks for exact matches. For exact matches, your filter should be `Cadence name` = 'Outbound - Short'. If you want to return all rows that contain that text then you want to use `Cadence name` LIKE '%Outbound - Short%'

  • david_cunningham
    Options

    Good catch @MichelleH! @Strongreece my comment on preview sometimes not showing rows in MagicETL when you are dealing with large datasets and a small result set still stands, but Michelle's answer should be selected as the correct solution to your post.

    David Cunningham

    ** Was this post helpful? Click Agree 😀, Like 👍️, or Awesome ❤️ below **
    ** Did this solve your problem? Accept it as a solution! ✔️**