CSP Error

Jazeppi Member
edited January 11 in Cards, Dashboards, Stories

I am building a ddx brick in DOMO. When I am editing the card, and I click "Run," everything functions fine and works correctly. However, when I click "Save and Finish," the brick/table loads all of the Column Headers but none of the table cells, and regardless of whether or not I refresh the page, the table cells do not load. When I inspected the console, I found the following error:

"[Report Only] Refused to frame '…' because an ancestor violates the following Content Security Policy directive: "frame-ancestors self:".

What is strange about this error is that my card used to work fine but, after making changes to the javascript portion of my code, the card stopped working. I know that CSP errors can be triggered by introducing external sources, however, I believe I did not do as such. Can someone explain to me how CSP errors work and possible ways I can troubleshoot the one I am getting? Thanks.


  • Ashleigh

    @Jazeppi sometimes I notice bugs in the Domo bricks that require me to just start over. I would try re making the brick and make sure it works and then make your changes to the JS code one step at a time by commenting it out and see if there is a particular section causing the bug.

    **If this answer solved your problem be sure to like it and accept it as a solution!

  • pshull

    @Jazeppi I ran into a similar issue and I kept running into CSP violation errors.

    It appears that DOMO only supports CDN links from two of the major CDN providers. You may be able to get additional sites whitelisted, but as far as I can tell, when working with Bricks, the DOMO team has to add the sites on their end. Here is what I found.

    Using a CDN (Content Delivery Network)Use a CDN to pull in your favorite libraries and frameworks (jQuery, d3, Vega, Phoenix, etc.)

    I switched out my script and style tags that were giving me issues and it resolved my issues. I hope this helps.