Formating

Options

I have 2 variables of which one must show as currency and other as just numbers.

I have tried to concatenate the dollar sign Infront of the main beast mode but I get an error on line 16.

What am I missing here?

Best Answer

  • MarkSnodgrass
    Answer ✓
    Options

    I would just not format the revenue as currency, but as a number with commas. I would think people will know without needing the $ sign.

    The other option would be to make two different fields, one for revenue and one for the other. Then, you can use the built-in formatting for each of them.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.

Answers

  • pauljames
    pauljames Contributor
    Options

    Case statements need else “category name” end language, I believe.

    IF I SOLVED YOUR PROBLEM, PLEASE "ACCEPT" MY ANSWER AS A SOLUTION. THANK YOU!

  • MarkSnodgrass
    Options

    Since you are concatenating inside your case statement, it becomes a string, so you can't sum it. You will not be able to have one value show up two different ways inside a sum. I would suggest just having your revenue case statement just return a number and the beast mode should work.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • carthur
    Options

    @MarkSnodgrass Thanks for the reply but if I only allow the revenue case statement to return only the revenue amount, I wil have to use the in built formating to make it show as currency. If that is the case when I toggle to use the other variable which is NOT currency it still shows as currency. How would I be able to change that?

  • MarkSnodgrass
    Answer ✓
    Options

    I would just not format the revenue as currency, but as a number with commas. I would think people will know without needing the $ sign.

    The other option would be to make two different fields, one for revenue and one for the other. Then, you can use the built-in formatting for each of them.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.