Exporting Mega Tables

Options

Do Mega Tables usually tell you if your export is missing data? I have a mega table with 100,000 rows but when I export, it gives me 50,000 but there is no error message saying it did not export all data.

**If this answer solved your problem be sure to like it and accept it as a solution!

Best Answer

  • CKunz
    CKunz Domo Employee
    Answer ✓
    Options

    @Ashleigh

    The limits for exporting from Mega Table to Excel are listed in this KB article:
    https://domo-support.domo.com/s/article/360043437813?language=en_US

    "When exporting to Excel, only data that is displayed in the Card will be exported, up to 1M cells of data while exporting to CSV will output all rows. For Megatables, Pivot tables, and HTML tables, this is 50k rows by default and up to 100k rows by manually increasing the row limit inside of Analyzer."

    Your Analyzer will likely say "All Rows", but if you change it to 100,000 then you will get 100,000 rows in your Excel export.

    I hope this helps!

Answers

  • MarkSnodgrass
    Options

    I believe it is a limitation with the Excel option when choosing Send/Export. I just tested with an mega table card that had 84k rows. When I chose Excel, it only exported 50k rows. When I chose CSV, I got all 84k rows.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • ST_-Superman-_
    Options

    It does seem like this should be something that you are warned about prior to exporting. Did you want to post this in the Ideas Exchange @Ashleigh ?


    “There is a superhero in all of us, we just need the courage to put on the cape.” -Superman
  • Ashleigh
    Options

    @ST_-Superman-_ yea I can post it there, I just wanted to double check it wasn't an error on my end because I've seen an excel report give an error before but I think it may have been for a pivot table export.

    **If this answer solved your problem be sure to like it and accept it as a solution!

  • CKunz
    CKunz Domo Employee
    Answer ✓
    Options

    @Ashleigh

    The limits for exporting from Mega Table to Excel are listed in this KB article:
    https://domo-support.domo.com/s/article/360043437813?language=en_US

    "When exporting to Excel, only data that is displayed in the Card will be exported, up to 1M cells of data while exporting to CSV will output all rows. For Megatables, Pivot tables, and HTML tables, this is 50k rows by default and up to 100k rows by manually increasing the row limit inside of Analyzer."

    Your Analyzer will likely say "All Rows", but if you change it to 100,000 then you will get 100,000 rows in your Excel export.

    I hope this helps!

  • Ashleigh
    Options

    @chasek thanks for the link! I guess it would be nice to have some sort of notice to remind users it did not export everything similar to what Pivot tables do. I will add that to the idea exchange.

    **If this answer solved your problem be sure to like it and accept it as a solution!