Pivot Table showing correct grand totals but not all records


I am counting story points from a jira import, and while all the records are in the base data, when I create a pivot, it shows correct grand totals but skips some records, and fails to do row totals correctly. Even when I remove filters.



  • Ashleigh

    @dgsinclair are you sorting by anything? That will usually mess up totals.

    **If this answer solved your problem be sure to like it and accept it as a solution!

  • dgsinclair

    Yes, I am sorting by Sprint. Let me try removing sort.

  • dgsinclair
    dgsinclair Member
    edited August 2022

    OMG, removing the sort on Developer (not the other 4 sort items ;) worked!

    Thank you thank you!!

    But is that a bug? Or a feature? What logic is being applied when I sort on Dev that it does not show all rows or do the totals correctly? Perhaps my Developer sort is conflicting with team sorting or something.

  • ST_-Superman-_

    @dgsinclair - For pivot tables, you can only sort on any fields that you have in the table itself. If you sort on anything else, then you will only see the first value in the table (although the totals will still be accurate).

    I believe this is intentional. You may want to highlight the largest deal won in a month, but then still show total sales. You could to this by sorted on deal value descending. You would then see the largest deal closed each month in the table, while the totals would reflect all deals closed.

    I think there could be an added message to alert you to this fact anytime that you add a field to the sorting list that isn't in the rows/columns of the pivot table.

    “There is a superhero in all of us, we just need the courage to put on the cape.” -Superman