How to get Domo to recognize numbering as 1,2,3,... instead of 1,10, 100, 110,...?

user04285 Member
edited March 2023 in Scheduled Reports

Hi, I have a daset that I want to build a Sumo card on. 

But as I build the card, it's clear that Domo tried to sort the categories by itself, causing the view to be something I don't quite want. 

I tired adding numbers before each category, but instead of arranging the numbers by 1,2,3,... Domo somehow arranged it to be in this structure 1,10,110,...

Why does Domo behave this way and how do I solve this problem?



  • Valiant

    So the reason it's doing this is that your category columns are being viewed as a text column instead of numeric.


    What you would need to do is add a separate column for ordering and then sort by this new ordering column. That will keep your categories in the correct order.


    Let me know if you have any other questions on how to do this,



    **Please mark "Accept as Solution" if this post solves your problem
    **Say "Thanks" by clicking the "heart" in the post that helped you.

  • AS

    It sounds like you're referring to Domo sorting by strings alphabetically, and 10 does come alphabetically before 2. What you need to do is separate your category names from the way those categories sort.

    This is often done with a custom beast mode calculation or a separate column that provides the sort order priority.


    The other option, if you want to maintain the number category combination, would be to zero-fill the numbers in order to force alphabetical sorting, like 001, 002, 003... 010, 011, 012... 100, 101, 102, etc.

    MajorDomo @ Merit Medical

    **Say "Thanks" by clicking the heart in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
This discussion has been closed.