Is it possible to fix the line chart to show a line even when I don't have data


Is it possible to show data as a line instead of points in the line charts? I've run into this on a number of occasions where I'd like the line to show flat between datapoints (when there's no data for a date range) instead of disappearing and showing up as individual points (see image below). 


Does anyone know if there's a chart setting (or chart type) that solves for this? The way it visualizes the data currently is rather non-intuitive.




  • Hi all,

    Can anybody help out @Kung-fu_Panda?


  • I am having the same problem as Kung-Fu_Panda. I would like to show a line trend for a certain day of the week and as soon as it is filtered to show only Friday data, the line breaks up. 

  • I found a workaround by forcing a 0 in a beast mode when the value is null in the column. It fixes the visualization issue, but it means more fields and confusion for end users.


    Would like to have a more elegant solution, and will keep noodling on it. If anybody has a better fix, I'd love to hear about it.


    Fixed version with beastmode



  • Domo used to actually not display lone datapoints at all and only showed connected lines.  So, there's that.  Sounds like you're asking for Domo to go one step further and connect the points, regardless of missing spots.

    Example: March at 10 and June at 15, with a straight line between the March and June, even though April and May are empty, where the line would usually go away.  Which is different than having a value of zero.


    If that's what you're asking for you'll probably have to submit the suggestion to the Ideas Exchange board.  Like a check box in the chart settings to continue lines where data is empty.  

    MajorDomo @ Merit Medical

    **Say "Thanks" by clicking the heart in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • Well, not really, all the data is there, so I'm not dealing with missing data other than taking out what I don't want to see. The x axis is a date, and when I filter to only show Fridays, the line breaks up. The first image is without the filter, the second one is when I filter to only show the data for Fridays. I didn't mean to hijack the thread, I can start a new one if it's necessary. Thanks.



  • Looks like it's still set up to show daily, then you've just filtered out the values on the other days.  Does the same thing happen if you graph by week?

    MajorDomo @ Merit Medical

    **Say "Thanks" by clicking the heart in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • I'm not sure, I'm pretty new to this. How would I change it to graph by week? Capture3.JPGIt does not break up if I use week number in the year instead of the date for the x axis, but the people in the corner offices don't want to see that, they want to see a date value.  I have also tried filtering the day in the dataflow instead of the graph and I get the same results. 


  • You can keep the regular date field on the X Axis but on the date picker choose to graph by week, instead of choosing the week number directly on the X Axis:

    date picker.JPG


    Then it will roll up to the week level.  At this point Domo gives two options for how to display the weekly labels on the axis.  You can see them by week number like 'Week 1 2016' or by first day of the week, like '1/1/2016'.  Most people prefer the latter in my experience.  And the place to toggle between the two options is on the Admin page under Company Overview (the same page where you give your Domo instance a name, pick a time zone, and choose a company logo).


    MajorDomo @ Merit Medical

    **Say "Thanks" by clicking the heart in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • Reporting back on the original issue. I worked with our data engineer and we applied the beast mode fix directly to the dataflow. This forced the null values to 0s and all the line charts now display as you would expect. The benefit to this over the beast mode was that we avoided multiple series in the data set with the same data. 


    This is still a workaround though for something that could be fixed in chart settings. It took extra coding and some problem solving on our part to get there. 


    Can we get this added to the chart properties as an option? Curious why the default on the chart was set to show points instead of direct lines...


    Happy to chat in more detail if anyone at Domo needs to see a repro of this, or walk through what we did to fix it.



  • Are you able to share the Beast Mode fix for this?

  • Trent-T
    Trent-T Member

    Is there a fix for this that can be shared?

This discussion has been closed.