How can I use a beast mode calculation as a filter?

Options

It appears that I cannot use a beast mode calculation as a filter. Every time I try to drag and drop the the field over the filter area it simply won't allow me. 

Comments

  • zcameron
    zcameron Domo Employee
    Options

    A beastmode calculation can be used as a filter, just not if it uses an aggregate function, such as SUM, AVG, MAX, etc. The reason for that is that filtering has to happen before aggregation. Filtering is meant to remove unwanted records so that calculations (aggregations)  and visualizations don't include values you don't want to see. If a beastmode contains an aggregate function, it is processed AFTER the filtering has been completed.

     

    Does that help clear up what's happening? 

  • kshah008
    kshah008 Contributor
    Options

    @mmalpass, did zcameron's reply help you out?

  • Wolfram
    Options

    This is incredibly limiting. Is there a way around this or plans to allow post-aggregation filtering?

     

    There are tons of legitimate use cases to filter on aggregations (e.g. filtering a sum minus another sum). Tableau can do this, why not Domo?

  • Godiepi
    Options
    A work around would be doing the calculations in a dataflow, so that each calculation creates a new column in your final dataset that can be easily use as a filter.
    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'