Host name for ElasticSearch Connector?

Hello, I am trying to set up an account for the premade ElasticSearch Connector. This connector requires three fields: Host, Username, and Password. I have a working username, password, and URL for manually logging into Elastic, however I have not been able to come up with a working permutation of the URL to use in the "Host" field.

If anyone has gotten this connector working, could you share an example of what the Host name should look like?



  • @mlee It would be a custom URL where your ElasticSearch is hosted, with a port number on the end of it. I've seen ones like these used in the past "" or ""

    If I have answered your question, please click "Yes" on my comment option.

  • Thank you for your response, TDanis! Unfortunately, that format is not working for me in the connector.

    The original URL sent to me looked like this:

    I am still able to manually log in when I shorten it to: - to match your example.

    However, neither of these are working in the connector. I've verified that I did not paste in any extra spaces in the username and password. Both of these contain at least one @ symbol, is there any chance that could be an issue? I have a support ticket open on this as well, and I'll let them know that you've seen this connector work with that format in the Host field.

    Here is the error that I am getting: Failed to authenticate. Verify the credentials and try again. Domo is ready, but the credentials you entered are invalid. Verify your account credentials and try again.

  • Another thing just occurred to me - is there more than one Elastic product? Maybe the connector is not for the same service that I have a login for.

  • @mlee There is only one ElasticSeach connector. That's good you have a support case. Engineering will likely need your credentials to debug the connector. We typically only see issues with escape characters being used in password fields. The only thing I could think of is if there is an IP restriction on that server but if you can log in and they didn't need your IP that's probably not it.

    If I have answered your question, please click "Yes" on my comment option.

  • Thank you, I've updated my ticket to request help from the engineering team.

  • Updating here in case anyone else has this issue.

    Mine worked using Host Name:

  • were you able to pull data using that hostname. I saw that listed on I wasn't sure if that was to just to be able to execute tasks.

    If I have answered your question, please click "Yes" on my comment option.

  • At the moment, I do not have experience with using/navigating Elastic or the field names that we need to bring in, so I have not yet tried to pull anything. I'll update here again when I test, and I'll edit my previous post if I find that I can't pull data.

  • mlee
    mlee Member

    I am working on this again, it took a while for me to get the Index name, and I'm now attempting to pull some data. I am still a bit unsure if I entered my query correctly, but, based on the error message, the issue seems to be elsewhere.

    I am getting this error - could this be related to the concern that was mentioned earlier? I am blocking out the index name with [indexName], which I tried with and without a "." at the start

    404 : Not Found : Error calling[indexName]/_search

    Here is the query that I entered:

    "query": {
    "match_phrase": {
    "message": "Impression"

  • user003262
    user003262 Domo Employee

    @mlee Here is a documentation link that will be helpful in creating your search query

  • mlee
    mlee Member

    Thank you, I'm reaching out for some more help with this. I don't have enough of a grasp of the data structure and field names to apply this information