Trouble connecting TikTok through email connector (Download directly from link in email)


Hi, there are a few TikTok metrics that are not available via the API connector, so I am attempting to use an email connector. The emailed report contains a download report button that triggers a link to open that automatically starts the download of an xlsx file. (I also tried with a csv)

I set the connector to use the file location 'download directly from link in email'

I have tried using the 'link matches a regex' with a string that appears in all of the download links. ^.*(OxqwZwwAVvYGpJMosQ).*?

I also tried the "link has a different string in it" with the same snippet that apprears in every downloaded link. 'OxqwZwwAVvYGpJMosQ'

Neither of these have worked and I get the error 'Domo is ready, but an email was received that did not contain the specified file type'

I think I just need to adjust the setting in the connector a bit, but cannot figure out the right combination. Any suggestions on these settings?


  • GrantSmith

    Hi @AnnieL

    Does the download link go to a website to click a button or link to download the excel file or does the link directly download the excel file?

    I think there may be an issue with Domo no being able to process a file from a link which redirects and starts downloading a file rather than directly linking directly to an excel file ( vs This is likely because when Domo makes the initial request and gets a redirect message instead of an actual file. I'm not 100% certain on this but this is what I gather is the case from my past experience.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • AnnieL

    Hey Grant,

    Thanks for the answer! I think I figured it out. The download link goes to tiktok but then we have to be logged in for the automatic download to work -- therefore the email connector fails. Going to look into other connecting options!

  • AaronP

    Hi Grant, Did you solve this issue? I having the same issue with pinterest