Using a postgresql connection that got upgraded to use SCRAM-SHA-256 authentication protocol

Options

Our database got upgraded to a new version of postgres and utilizes SCRAM-SHA-256 authentication protocol and it's causing an error in our authentication scheme. There seems to be no option to choose the authentication scheme, or is there settings that are not in the Postgresql connector?

Error setting up SQL connection. The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.

Best Answer

  • ArborRose
    ArborRose Coach
    Answer ✓
    Options

    I haven't worked with Postgre in a minute. But based on your description and some googling…it seems the error is looking for you to check that you have your protocol set using method as scram-sha-256 in the pg_hba.conf configuration file. Found in the PostgreSQL data directory. I'm not sure it will make a difference to the Domo connection though.

    TYPE  DATABASE        USER            ADDRESS                 METHOD
    host    all             all             192.168.1.0/24          scram-sha-256
    


    reference:

    Authentication Methods: Various methods can be used for authentication, including:

    • trust: Allows the connection without requiring a password.
    • password: Requires a password.
    • md5: Requires MD5-encrypted passwords.
    • scram-sha-256: Requires SCRAM-SHA-256 authentication.
    • reject: Rejects connections outright.
    • peer: Uses the operating system user name for authentication (local connections).

    ** Was this post helpful? Click Agree or Like below. **
    ** Did this solve your problem? Accept it as a solution! **

Answers

  • ArborRose
    ArborRose Coach
    Answer ✓
    Options

    I haven't worked with Postgre in a minute. But based on your description and some googling…it seems the error is looking for you to check that you have your protocol set using method as scram-sha-256 in the pg_hba.conf configuration file. Found in the PostgreSQL data directory. I'm not sure it will make a difference to the Domo connection though.

    TYPE  DATABASE        USER            ADDRESS                 METHOD
    host    all             all             192.168.1.0/24          scram-sha-256
    


    reference:

    Authentication Methods: Various methods can be used for authentication, including:

    • trust: Allows the connection without requiring a password.
    • password: Requires a password.
    • md5: Requires MD5-encrypted passwords.
    • scram-sha-256: Requires SCRAM-SHA-256 authentication.
    • reject: Rejects connections outright.
    • peer: Uses the operating system user name for authentication (local connections).

    ** Was this post helpful? Click Agree or Like below. **
    ** Did this solve your problem? Accept it as a solution! **