Data Formatting

Options
damen
damen Contributor

Hi All,

I am working with a number that doesn't seem that big but when domo ingests the excel file, it is wanted to add scientific notation to it.

I need the numbers in the format they were entered in. I am in Magic ETL.

Can anyone help?

If this helps, feel free to agree, accept or awesome it!

Tagged:

Best Answers

  • Data_Devon
    Data_Devon Member
    Answer โœ“
    Options

    I've had a similar issue in the past wherein a number was imported into Domo and inadvertently rounded. The number was an ID number, so rounding it renders the ID useless. (I.e. ID Number 999 and Domo rounded it to 1000 ๐Ÿ˜)

    The work around I found was to uncheck the "Use Raw Numbers" at the File upload point. This imports the values as text, so that Domo doesn't apply any mathematical logic and therefore retains the original values.

    Downstream from there you can then convert Text to Number or Integer if you need to perform Math on the values.

    Am I on the right track here?

  • JasonAltenburg
    Answer โœ“
    Options

    Are you certain this is a Domo issue and not an Excel issue?

    In my experience, this issue can arise if you are opening a csv in Excel with raw numbers greater than 15 digits, then saving it in an excel type format. See this article for additional info.

    https://learn.microsoft.com/en-us/office/troubleshoot/excel/last-digits-changed-to-zeros

Answers

  • Data_Devon
    Data_Devon Member
    Answer โœ“
    Options

    I've had a similar issue in the past wherein a number was imported into Domo and inadvertently rounded. The number was an ID number, so rounding it renders the ID useless. (I.e. ID Number 999 and Domo rounded it to 1000 ๐Ÿ˜)

    The work around I found was to uncheck the "Use Raw Numbers" at the File upload point. This imports the values as text, so that Domo doesn't apply any mathematical logic and therefore retains the original values.

    Downstream from there you can then convert Text to Number or Integer if you need to perform Math on the values.

    Am I on the right track here?

  • JasonAltenburg
    Answer โœ“
    Options

    Are you certain this is a Domo issue and not an Excel issue?

    In my experience, this issue can arise if you are opening a csv in Excel with raw numbers greater than 15 digits, then saving it in an excel type format. See this article for additional info.

    https://learn.microsoft.com/en-us/office/troubleshoot/excel/last-digits-changed-to-zeros