Interactive Calendar Filter

Options
Atieh
Atieh Member

I need help to create an interactive calendar filter.

I have 4 filters: Fiscal year, Fiscal quarter, Fiscal month and wanted to add a calendar for the custom range which is interactive with other filters:

The problem is that when I select the fiscals, the calendar is not changing base on the selection:

Based on above selections, my calendar should show month of April only, but it is not happening

Tagged:

Best Answer

Answers

  • ColemenWilson
    Options

    I have done a ton of testing and I am quite sure this is a bug. I would submit a support case to Domo to investigate.

    If I solved your problem, please select "yes" above

  • MichelleH
    Options

    @Atieh Are your filters and calendar card powered by the same dataset? If not, be sure that the dataset powering the calendar card contains fields Fiscal year, Fiscal quarter, and Fiscal month.

    As a side note, have you enabled a fiscal calendar in your instance? If not I recommend creating one so that you can use the Global Date filters on your dashboard instead of having to create multiple filter cards

  • Atieh
    Atieh Member
    Options

    @MichelleH yes! Same dataset

    For the fiscal calendar should I ask support to implement it for us?

  • ColemenWilson
    Answer ✓
    Options

    Here is how to get the fiscal calendar in Domo: https://domo-support.domo.com/s/article/360042924254?language=en_US

    But even then you will have issues. I replicated what you are trying to do in my instance and am getting the same result. It is a bug I am pretty sure.

    If I solved your problem, please select "yes" above

  • MichelleH
    Options

    @Atieh Yes, support should be able to help you with the bug and implementing the fiscal calendar!

  • Atieh
    Atieh Member
    Options

    @ColemenWilson

    I guess we have already set it up as the option is available for me

    I will open a support ticket for it. Thanks!

  • ColemenWilson
    Options

    No problem! Happy to help.

    If I solved your problem, please select "yes" above