Data on multiple lines

Options

My data is showing on multiple lines even though the parameters are the same. For example, as shown below the area (Boca Del Ray) and the discipline (COTA) are the same, but it's showing separate lines with different data for the measures. I want each area and discipline to show only once. This happens throughout the full data set. Is there a way to ensure it's combined in one row?

Best Answers

  • david_cunningham
    edited May 1 Answer ✓
    Options

    By trailing white space I mean something like this.

    "BOCA DEL RAY" vs "BOCA DEL RAY "

    In any case though, it looks like the reason is that your beast mode is calculating a percentage, but you're not aggregating that percentage. See how you have 2 different values for BOCA DEL RAY

    You'll need to either wrap your beast mode in a AVG/MIN/MAX function, or you should be able to select that by setting the Aggregation context from the column pill

    David Cunningham

    ** Was this post helpful? Click Agree 😀, Like 👍️, or Awesome ❤️ below **
    ** Did this solve your problem? Accept it as a solution! ✔️**

  • EChampagne
    EChampagne Member
    Answer ✓
    Options

    Got it - thank you!

Answers

  • david_cunningham
    Options

    Are you absolutely certain those 2 rows are the same? I’ve had this happen before where 1 had a trailing white space.

    Also, not sure what the logic is for your Open Capacity beast mode, but make sure it is aggregating.

    David Cunningham

    ** Was this post helpful? Click Agree 😀, Like 👍️, or Awesome ❤️ below **
    ** Did this solve your problem? Accept it as a solution! ✔️**

  • EChampagne
    EChampagne Member
    Options

    What do you mean by a trailing white space?

    Open capacity is a calculated field: ((Visits Agreed Upon-Billable activities)/Visits Agreed Upon).

    Essentially it's taking the columns "contracted" minus billable activities over contracted.

  • david_cunningham
    edited May 1 Answer ✓
    Options

    By trailing white space I mean something like this.

    "BOCA DEL RAY" vs "BOCA DEL RAY "

    In any case though, it looks like the reason is that your beast mode is calculating a percentage, but you're not aggregating that percentage. See how you have 2 different values for BOCA DEL RAY

    You'll need to either wrap your beast mode in a AVG/MIN/MAX function, or you should be able to select that by setting the Aggregation context from the column pill

    David Cunningham

    ** Was this post helpful? Click Agree 😀, Like 👍️, or Awesome ❤️ below **
    ** Did this solve your problem? Accept it as a solution! ✔️**

  • EChampagne
    EChampagne Member
    Answer ✓
    Options

    Got it - thank you!

  • Sean_Tully
    Sean_Tully Contributor
    Options

    I think david's point about the beast mode lacking aggregation is the issue. It should probably look like this:

     sum(Visits Agreed Upon-Billable activities)/sum(Visits Agreed Upon)