Changing to date format

Options

Hello,

I am having the following trouble when changing the data type inside an ETL: basically I cannot change this string format to a date format:

Any help would be greatly appreciated!

Best Answers

  • MarkSnodgrass
    Answer ✓
    Options

    You should be able to use the CONCAT to add a day on the end, such as 1 and then convert it to a date. Like this:

    DATE(CONCAT(datefield,'-01'))

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • GrantSmith
    GrantSmith Coach
    Answer ✓
    Options

    On your input dataset you can go to the configuration tab, find your field and then change it to Date data type. If you click the gear next to the field you'll then see a Date settings submenu. Go into that and you can set your date format there: %Y-%m

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**

Answers

  • MarkSnodgrass
    Answer ✓
    Options

    You should be able to use the CONCAT to add a day on the end, such as 1 and then convert it to a date. Like this:

    DATE(CONCAT(datefield,'-01'))

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • GrantSmith
    GrantSmith Coach
    Answer ✓
    Options

    On your input dataset you can go to the configuration tab, find your field and then change it to Date data type. If you click the gear next to the field you'll then see a Date settings submenu. Go into that and you can set your date format there: %Y-%m

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**