Default date filter on dashboard not affecting cards


I've checked and interaction is enabled for all cards on the dashboard. Across all the cards on the dash, I'm only using one specific Date field. Also I checked Edit > Filter Options and "Allow Global Date Filters" is selected. Does anyone know how to get this default date filter to affect the cards?

For example, when I go to top right and select "Choose Date" and under "Graph By", select Month, I'd like it to change the cards to a monthly aggregation. Right now, it does nothing to the cards. Thank you!


  • GrantSmith

    Are you using a date field in the graph? Does your data have different date values or are they all the same date? Can you post a redacted screenshot of your analyzer with the date picker expanded?

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • I would click on Edit Dashboard and then on each card, click Edit Content and click on Change Filter Exceptions. Ensure that the Allow global date option is selected.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • AO3

    So I figured it out I think. You can see in the attached picture I had "Week Start Date" selected as the date field, but when going to analyzer and expanding date drop down, I had it as "Last 12 weeks", but then here was the problem…I had "Graph By" set to "None"

    Now there is a specific reason I do this. Our company looks at everything by Week and we define a Week Start Date as Monday, where Domo defines it as Sunday. So I need to set it to Graph By = "None", because if I choose Graph By = "Week", it will list out the weeks using Sunday's dates, which won't match up with any of our internal company data.

    Any ideas on how to get Domo to default to Monday starting the week instead of Sunday? thanks for all the help!