Single Value Card - Value is 0

Options

I am calculating the NPS score of a survey dataset. Today, the NPS Score is 0. When doing a table, it will show 0.0 but when I switch it to a Single Value Card, it is just blank and does not display 0. I cant find a property to help with allowing 0s. Any ideas?

Best Answers

  • MarkSnodgrass
    Answer ✓
    Options

    I would put survey type in your filter and filter to 2 and then just have your beast mode do the summing and not the case statement like this:

    ((sum(Promoter Count) - sum(Detractor Count)) / sum(NPS Count))*100

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • MichelleH
    MichelleH Coach
    Answer ✓
    Options

    I agree with @MarkSnodgrass's suggestion for the single value card. If you want to show the First Week and Second Week in the same card, then I would suggest adding the week 2 filtering inside each sum using case statements:

    ((sum(Case WHEN `Survey Type` = '2 Week Survey' THEN `Promoter Count` end) - sum(Case WHEN `Survey Type` = '2 Week Survey' THEN `Detractor Count` end)) / sum(Case WHEN `Survey Type` = '2 Week Survey' THEN `NPS Count` end))*100

Answers

  • MarkSnodgrass
    Options

    It's odd that is blank, but the first thing I would try would be go to General - No Data Handling and choose Zero Value and see if that works.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • MThebeau
    Options

    Unfortunately that did not do the trick. Still showing blank.

  • MarkSnodgrass
    Options

    Are you able to choose an aggregation type in the value, such as SUM? Or is your aggregation done in the beast mode that is being used in the value?

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • MThebeau
    Options

    The aggregation is done in Beast Mode. I have the same beast mode calculation for a different survey type in the same data set and it is working.

  • MichelleH
    Options

    @MThebeau Can you please share your beast mode code so we can look into it further?

  • MThebeau
    Options

    Case WHEN
    Survey Type= '2 Week Survey' THEN

    ((sum(Promoter Count) - sum(Detractor Count)) / sum(NPS Count))*100

    END

  • MarkSnodgrass
    Options

    I agree with @MichelleH that it would be helpful to see the beast mode. Also, check what you have in the sorting properties. That can throw off what is being displayed since the single value card will only display one row. You could also try adding your beast mode to your filter and filter to where the value is not blank.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • MarkSnodgrass
    Answer ✓
    Options

    I would put survey type in your filter and filter to 2 and then just have your beast mode do the summing and not the case statement like this:

    ((sum(Promoter Count) - sum(Detractor Count)) / sum(NPS Count))*100

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • MThebeau
    Options

    @MarkSnodgrass the filter worked! Thank you!

  • MichelleH
    MichelleH Coach
    Answer ✓
    Options

    I agree with @MarkSnodgrass's suggestion for the single value card. If you want to show the First Week and Second Week in the same card, then I would suggest adding the week 2 filtering inside each sum using case statements:

    ((sum(Case WHEN `Survey Type` = '2 Week Survey' THEN `Promoter Count` end) - sum(Case WHEN `Survey Type` = '2 Week Survey' THEN `Detractor Count` end)) / sum(Case WHEN `Survey Type` = '2 Week Survey' THEN `NPS Count` end))*100