Set job schedule

I have a job scheduled to run more than once a day between 6 am and 11 pm. We have a database maintenance running between roughly 3 am and 6 am, so we do not want Domo jobs to refresh data during that time, however, we receive error messages that the job could not complete: Domo Workbench encountered an error loading data into the <job name> data source.  How can this message be turned off?


  • @user02055 You can turn off error emails by deselecting the "Notify on Error" checkbox in the Notifications tab on your Workbench job:

    However, I would recommend adjusting the schedule to start a little after 6 am to account for the scheduled maintenance rather than turning off error notifications all together.

  • The job only runs between 6am and 11pm, so there should be no emails because the job should not be running.

  • @user02055 In that case it sounds like there is a problem with your workbench schedule or your database maintenance is taking longer than anticipated. What time do you usually get the error emails?

  • They come in at 3:00am and 4:00am and occasionally at 5:00am. The job starts at 6:00am and its last run is at around 11 pm. When I look at the schedule, it meets my expectations of having no jobs active between 11pm and 6am. I've completely recreated the job from scratch twice just in case it was a problem with the configuration, but that did not fix it.

  • @user02055 Can you confirm that there are no other jobs enabled for this same dataset?

  • I thought there might be another job running, but the message contains the job's specific name, so I don't think so. Is there a way to see other jobs that might be interfering? Maybe I'm not looking in the right place to see them.

  • @user02055 Just to be safe, try searching your job list screen for the name of the job to see if there are multiple. It may also be worth checking with any other Workbench users to see if they had any other jobs enabled.

  • There is another job that runs at this time. It uses the same stored procedure, but has a different job name. I think you may be on to something though. I'll contact the colleague who scheduled the other job to see if it can be turned off so errors aren't generated. I wouldn't think this is the problem since they are distinctly different jobs, but I don't know about the internal workings of Domo.