Email Connector - csv headers import, but not data

I am emailing a csv to an email connector that worked in the past. I changed update to Replace so that I could amend the data structure before I set it back to Append.

The replace with the new CSV is not working - it pulls in the headers but no rows of data. HELP! Thanks. My settings are basic:



  • I tried csv with and without UTF8 encoding, I tried xlsx, still does NOT import the data. Created a NEW data connector and same issue. ARGH!

  • @dgsinclair What specifically are you changing about the data structure of your file?

  • @dgsinclair can you share a screenshot of what the data looks like before you send? Also can you send a screenshot of the history of the email connector? It should tell you how many rows were updated

    John Le

    You're only one dashboard away. 

    More video solutions at:

    John Le

    You're only one dashboard away.

    Click here for more video solutions:

  • Yesterday I downloaded the csv of the existing data, and cleaned it up, including removing a column. I then set the Update method to Replace. And now it doesn't work. This same CSV doesn't work with a new connector either, so I suspect it's the csv. Perhaps the header row has an issue? or the first row? Appreciate your help.



  • @dgsinclair It most likely is the CSV file you're using. I'd suggest reverting your dataset back to the last successful execution from January 5 and starting your changes again from scratch.

    On a side note, did you edit the csv file in a text editor, like your screenshot, or did you use Excel? If you did it in a text editor, it's possible that you may have accidentally mis-aligned your columns while manually editing and Domo is unable to read it properly.

  • Thanks I'll try that. I edited in Excel and just resaved it