Export card to Excel using API


I have a card containing numerous beastmodes and I can export to Excel through the UI and maintain the look of the card as well as all the filters. Is it possible to do this same action through the API? From the documentation I only see the option to query datasets, which we have done extensively, but I would want to query the data that has been transformed inside the card itself via these beastmodes.\

Thanks in advance!


  • EricVanDerEems
    EricVanDerEems Domo Employee

    Hi Logan,

    Try exporting as a CSV instead of XLS. This tends to preserve the data better.

  • MarkSnodgrass

    @loganherzog If you watch the network traffic in your browser when you view a card and click on share and choose Excel, you can see the API call that is being made and the necessary headers. You can call those same APIs within your application. You will just need to know the card id for each you want to export.

    Hope this helps.

    **Check out my Domo Tips & Tricks Videos

    **Make sure to <3 any users posts that helped you.
    **Please mark as accepted the ones who solved your issue.
  • jaeW_at_Onyx

    you can convert your card into a table from the Card Details pane and you can export your data from the UI.

    if you monitor network traffic you can see the API request that's being sent by the browser.


    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • anzulfa

    Hi @MarkSnodgrass I'm facing this same issue. I've tried calling the api from the network traffic when I view a card and click export to excel. I used the authorization token from the documentation here https://developer.domo.com/docs/authentication/overview-4, but I got this following error:


    "status": 401,

    "statusReason": "Unauthorized",

    "path": "/api/content/v1/cards/883344738/export",

    "message": "Full authentication is required to access this resource",

    "toe": "7OE8P5JR31-LLO4L-D0L4M"


    Do you have any idea why this happened? Thank you.