Date field not recognized while data upload

I have been using Domo for almost 2 years now and all this while, any data which I uploaded had date fields in format either YYYY-MM-DD or YYYY-MM-DD HH:MM:SS which has been the recognized date format so far.


Any such data uploaded in data set via file upload or FTP pull or any other method automatically identified the field as 'Date' format and showed the date as Jan 1, 2020 and so on.


However, since last couple of days, this format is not working for me and the fields are note being recognized as date fields but 'text' which is a blocker for me in terms of working with new data set and create time frame based cards.


Interestingly, a couple of my colleagues do face the same issue (all windows user) while things work normally and as expected for one other colleague (mac user) ( which I think - OS should not be impacting the cloud solutions - but still thought of mentioning this)


My question is - has anyone faced any similar issue or is aware of any recent changes.

Any suggestions on how I can make it work would be appreciated. ( I am trying to upload csv files) 

I have attached image of the issue being faced with the date field.


P.S.: Domo Support team is taking forever to respond on this - This increases my trust on this Dojo Community Space


  • Hi @Akhil 

    Have you tried making sure your date field is all formatted as a date or a date with time (not mixing formats but a consistent format)? If you're only using the date and don't care about the time have you tried just formatting your data as a date? Another option might be to split out the date and times into two separate columns.

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**
  • generally if the data does not upload in a recognized format, it implies that there is an issue with the data preventing CAST as date.


    but to verify.  Have you and your colleague (with Windows and Mac) tried uploading the same file on your respective machines using the same method?  I would be surprised if it made a difference; however, if it does, the second thing I'd check is if your machines have date / time formatted the same way in your regional settings on your desktops.


    Additionally, try opening the dataset in Magic ETL and converting the data to Date and DateTime and verify that when ETL is successfully able to convert it.   In most cases there is one row that has a space instead of NULL (for example) or a hand entered date adjustment that was mistyped and therefore breaks the ingest process.

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"
  • @GrantSmith - Thank you for your reponse.

    I have tried with other file uploads with consistent format of date fields as well, one column with date in YYYY-MM-DD format and other column with YYYY-MM-DD HH:MM:SS format.


    However, none of them is working since last couple of days.


    It has been working so far as expected ever since I have been using Domo.

  • @jaeW_at_Onyx  Thank you for your response. 

    Me and my colleagues tried uploading the same file from our respective systems and it worked correct only for one user out of three. Interestingly all the settings on the system (including date format) is same on all three systems.


    Additionally, Domo being a cloud solution, gives an Idea that the system OS or settings should not impact it anyways.


    I am sure ETL would solve the issue, but my concern  is it would add additional processing step before being able to use the data for card building, specially when we are using large data sets.

    This has been working fine for me so far.

  • That is interesting and definitely sounds like a bug that you should escalate to [email protected]


    They'll have access to logs which will help identify why the behavior is different...

    Jae Wilson
    Check out my 🎥 Domo Training YouTube Channel 👨‍💻

    **Say "Thanks" by clicking the ❤️ in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"