Workbench connecting to MS SQL Server "Value cannot be null. Parameter name: input"


Hi all,

I am trying to set up a Workbench job to connect to a MS SQL Server databsae and am getting the error:

"Value cannot be null.
Parameter name: input"


I have tried with the AWS RDS instance I am connecting to as well as a local MSSQL DB instance on my laptop.


Could you please explain what is the "input" parameter which is null and what value it needs to be set to?


I am using

[Overview Type]

Transport Type: ODBC Connection Provider

Reader Type: Database Query

DataSet Name: JY MSSQL Test Dataset

DataSet Type: Workbench ODBC

DataSet Description: MS SQL Server Test Dataset



Connection Builder:

Driver: SQL Server 64-bit

Server: <my servername>

Port: 1433

Database: <my db name>

Username: <my user name>

Password: <my password>

Connection Parameters: <blank>


  • BrendanH
    BrendanH Domo Employee


    What version of workbench are you using and is this an ODBC connection?

  • user10780

    thanks for the reply!

    Version 5.0

    Yes, it is an ODBC connection as I can connect using ODBC for IBM DataStage, and I can also connect using SQL Server Management studio on my laptop


  • Aymeric



    I receive the same error message when using the Sharepoint ODBC Driver from CData (


    Any idea what is the "input" parameter?



  • Hey there,


    I get the same error when I copy and paste from SQL Server Management Studio and don't remove the carriage returns or return characters.  Try removing the return characters (use Notepad++ or similar) and the disappearing query and error in the title should go away.

This discussion has been closed.