Filtering out rows by column value doesn't work?


I'm relatively new to Domo, but I feel like I've mastered most of it, including Workbench (I'm a software developer, so I can usually get ahead on things like this fairly quickly).  Specifically, I've had plenty of success with using lookups to join data in Workbench, as well as regular expressions to transform data.  However, there is one sort of transform that has never worked: filtering.


For instance, I have a data set that includes a column containing a part number, some of which I'd like to ignore.  I created a filter to exclude rows where part number begins with "FB_" (such as "FB_Item", "FB_Discount_Expense", etc), so the appropriate regular expression for the filter would be: ^FB_.+$.  However, this filter seems to have no effect.


This is the second time I've attempted to use the filter transform on a data set.  During the first attempt, I tried all sorts of things, including just a plain text match of the exact string, and that still didn't work.


In both attempts, the data set was a QuickBooks file, so I can't say whether the filter transform worked for another type, so perhaps filtering is broken only for QuickBooks data sets?  The only other types of data sets I have are ODBC, and I simply use SQL to filter out the data I don't want, but I don't have that capability with a QuickBooks data set, so I thought a filter transform was the way to do it.


I've attached a pair of screenshots, one showing the filter, the other showing a preview with rows that should have been excluded.


Am I missing something?

This discussion has been closed.