Beast Mode validated but still shows error in card


Error message: 

An issue has occurred during processing. We are unable to complete the request at this time.
(case when `Make_It_Personal` is null then 0
when `Make_It_Personal` = 'N/A' then 0 else `Make_It_Personal`*1 end)
The field name is "Make_It_Personal" and it's in text format. Possible values are (0-10, N/A, and NULL) so I used above code to convert this field into numbers so I can aggregate. It's giving me error only for feb, 2018 but not Jan 2018 or Dec 2017. I used excel to see if there's any other values i didn't account for or non-printable characters but found none. After dedupping the field it's still only 0-10, N/A, and null in excel. i also did the aggregate function outside of case function but not working.
I have attached the underlying data with sensitive fields removed. There are 2 other fields that are part of the calculation using the same code and they are working..  Literally have no clue why this is happening. HELP!!! PLEAE HELP!


  • Valiant

    Using your sample data this seemed to work on my end:

    CASE WHEN `Make_It_Personal` *0 != `Make_It_Personal` THEN `Make_It_Personal` * 1 ELSE 0 END

    Let me know if that wasn't what you were looking for.





    **Please mark "Accept as Solution" if this post solves your problem
    **Say "Thanks" by clicking the "heart" in the post that helped you.

  • user03579

    Hi ValiantSpur,


    Thanks for your fast response!

    Your code did not work for me. However my code worked after I imported this test data set and created a test card with the exact same code that was breaking..  So some how after I exported the dataset (ODBC) into excel then reimport the same data using excel connector, it worked... Is this a bug within Domo?


    Update: I uploaded the entire original export of the excel data and created test cards and it's not working. However, if I copied all data into a new spreadsheet and upload it, it's working. I used the "exact" excel formula to check every single cell of the data and between the original sheet and copied sheet and they all match. Something funky is going on in the ODBC dataset.. HELP!!