Group By function appears to have broken in the ETL UI (but not the actual processing of saved ETLs)


I set up some ETLs a bit over a week ago that utilise the group by function to mind the max(_LAST_BATCH_DATE_) and then join that back up to allow me to filter for only the most recent version of the record.


Since then:

  • the ETL was still running correctly and putting data through as expected
  • opening the ETL shows the Group By node as broken (even though its specified correctly)...first picture
  • I've tried fresh ETLs with simple Group By nodes....but they're broken there as well

It appears to be a UI bug:

  • Create Group By node
  • specify the node properly
  • click on the aggregation and you get the full list of applicable aggregation methods
  • click off the node (anywhere that causes the node to lose focus)
  • click back on the aggregation method
  • get the message 'No matches found'


This kind of stuff is making me consider making the decision to churn the company to another platform. What should have been a 5 minute task to build-it-just-like-the-other-10-dataflows-that-are-working, as is often the case with Domo, has wasted well over an hour of mine and my teams time.


  • DataMaven

    Let's see if any of these help:

    1 - Have you used the Maximum function with a Date/Time field before?  I wonder if it only works on numbers.  (I assume you have - just throwing it out there.)

    2 - When you run a preview, are you seeing the relevant fields populating in the append query?  In particular, make sure that "_BATCH_LAST_RUN_" is carrying through properly.  

    3 - I notice that in your final screenshot, "Add Column" is greyed out.  That is strange.  I would delete the transform and do it again, but I am sure you already tried that.  


    If none of these pertain, would you mind providing your field names and sample values?  

    Best of luck!


    Breaking Down Silos - Building Bridges
    **Say "Thanks" by clicking a reaction in the post that helped you.
    **Please mark the post that solves your problem by clicking on "Accept as Solution"