How do you create a publication group and filter pages for specific clients?

edited March 13 in Datasets

I am working to distribute publication groups to a group of external clients. For the most part, all of the cards and pages will be the same but some of my clients require special pages that I need to hide from other clients. 


1) How do I create a publication group?

2) How do I limit page access to some clients who do not care to see additional data points? 



Best Answer

  • I have solved my sharing issue. It turns out that I was sharing my original unfiltered dashboard with my test user. I removed the sharing, and it works perfectly fine.


  • To setup a publication group you need to the following: 

    Open the Admin section

    Screen Shot 2018-01-26 at 4.36.35 PM.png

















    In the Admin section select Publication Groups and then click "New Publication Group at the bottom"

    Screen Shot 2018-01-26 at 4.35.51 PM.png


    Start by naming your publication group

    In the first section you will define your page (which pages do you want to share). Note that pages listed here do not need to be shared specifically with your users, the publication group will do it automatically once it's created.

    Screen Shot 2018-01-26 at 4.38.40 PM.png

    With your pages added, the next step is to define your dataset permissions. Whatever cards are found the pages you added in the previous step will have their associated datasets displayed here. There are 3 options for each dataset (No Access, Filter Access and Full Access). The first and last option should be self-explanatory, the Filter Access option allows you to pick a column from the dataset to limit the rows returned for each individual user (ie, email address, employeenumber, etc) These are matched against their set field in Domo. 

    Screen Shot 2018-01-26 at 4.41.18 PM.png


    The last option is the User/Group Section where you can define what users or groups in Domo should have access via the publication group to the pages you defined. Just click the "New Access Group" button and a box will pop-up for you to search users and groups to assign.

    Screen Shot 2018-01-26 at 4.43.54 PM.png

    With those things in mind, the way I would go about limiting by specific clients would be to first have groups for each client (ex. GroupA, GroupB etc). I would then create a publication group for GroupA, add filter access for data they should selectively see, and set it to group. The one thing you'll have to keep in mind is that you have to tie your publication filter to the dataset, so for CompanyA, i would want the name GroupA to found in the Company field. So that my dataset filter would read

    Filter Access: Company = Group

    And then just make sure to add GroupA to your Access Groups section.


    Hope that wasn't an information overload. If you have any questions, just let me know and I'll try to clarify.




    **Please mark "Accept as Solution" if this post solves your problem
    **Say "Thanks" by clicking the "heart" in the post that helped you.

  • Hi,


    I am having a problem with setting up a Publication Group / filtered access.


    I followed the steps outlined in your post to define filtered access:

    I created a new user and gave it general asscces.

    I created a new group, added this user to the Group, and gave the group access to the Dashboard I created.

    I created a Publication Group, defined filters based on a team_name column, and added my group to the Publication Group.

    When I click on the eye icon to check how the dashboard looks with the filter, it works the way I want it.


    The problem though is that when I log in as the user from my phone, the filters are not applied, and I see all records.


    Is there anything I am missing? Please advise.


    Thank you!

  • I have solved my sharing issue. It turns out that I was sharing my original unfiltered dashboard with my test user. I removed the sharing, and it works perfectly fine.