Date filters in DOMO API

Options

Hi,

 

I am trying to apply date filter such as todate and last while fetching data through API from DOMO but the filter is not working for me.

 

I am using the following syntax:

 

GET /data/v1/:alias?createdAt last 3 months

createdAt:- is the domo date field that is returned through the API.

 

This syntax is not working for me.

 

Can anyone help and suggest me the way of applying date filters

Comments

  • Chronos
    Options

    Is anyone able to help out with this request?

  • NWolf
    NWolf Domo Employee
    Options

    Hi,

     

    We have some great documentation explaining api calls, which can be found at developer.domo.com. This will be a great starting point to help give you a better understanding of constructing the call you will need to get your data.

    If you’re getting stuck, we can reach out to your Customer Success Manager to help get you lined up with additional training.

    One thing I did notice is that I don’t see the “CreatedAt” command in the “Getting Data” section of our documentation, which is found here: https://developer.domo.com/docs/dev-studio/getting-data.

    The CreatedAt command is found in the “Stream API” Reference article: https://developer.domo.com/docs/streams-api-reference/streams.

    Thanks.

     

    -Domo Support

    If I have answered your question, please click “Yes” on my comments option.

This discussion has been closed.