Google Analytics Custom Dimension falsely interpreted as number

Options

Hi everyone,

 

I have created a custom report in the GA Connector but correctly importing the most important column doesn't work properly.

 

The GA Client ID is a string of the following format: "1234567890.1234567890". When this is imported, Domo sees it as a number and cuts off some digits in the end.

 

This is what I tried to fix it (nothing worked):

 

  1. Export the data to Excel -> more digits are reveiled but not all the whole string
  2. Use Magic ETL to convert the column into a number with more decimals -> still missing digits (and the original form isn't kept, so blending with other data sources doesn't work)
  3. Contacted Live Chat -> "Please leave as feedback."
  4. Left as feedback to the product team -> silence until now.

 

Does anyone have another idea how to tackle this?

 

Thanks,

Rob

Comments

  • Chronos
    Options

    Is anyone able to help out with this request?

  • bwardell
    bwardell Domo Employee
    Options

    Hey there,

    As far as digits are concerned, we only support numbers up to 18 digits.

    Currently, there is only 3 ways to force a column type.  

    1. Through Domo Workbench,

    2. Through the Domo API.

    3. You can add some sort of character to each row in your data before it comes into Domo.

    Regarding the feedback you gave, to have it escalated, please contact your Customer Success Manager and Account Executive. 

    Thank you!

    Brandon Wardell
    Associate Technical Advisor