No data when drilling down into a different dataset

I created a card with 2 drill path cards.  The top two levels are from the same dataset, while the bottom level is from a different dataset.  While they are compatible, the 2nd drill path doesn't show any data.  But if I simply pass the same conditions to filter using that dataset, there are expected data returned.  How can I troubleshoot to find out why the drill path did not work?


My card looks like this (made-up data):


From a dataset with all Summary info:

Level 1:




Total Team Count: 3


Level 2: (on Name = Q3)


Team Summary


Total Task Count: 2


Total Task Count: 6


Total Task Count: 3


Level 3: (on Name = Q3 and Team = "A"), from a different dataset containing more details

Expected to have something like below returned, but nothing returns.  If I use (Name = Q3 and Team = "A") directly applying on the details dataset, then I get the result.  But why are the conditions not being passed (?) when the dataset is a drillpath?








How can I troubleshoot?




  • I am having the same issue as Hua.  Has there been any response?


    I can build the drill down cards and see the data while I'm editing the input values, but the cards are coming up blank when I drill down from the view.


    This is a dataset that I customized using an SQL dataflow to match the input values to the original dataset so it could be utilized for the drill down. 




  • Hi all,

    Can anybody help out @Hua and @JCB76?


  • Hi @Hua the key to using different datasets in a drill path is that the fields powering the cards must have the same names in each dataset. 


    Can you confirm that the fields you are clicking on when drilling are named the same in both datasets?


    If the fields are all properly named, then it might be a good idea at that point to engage Domo Support or your Customer Success Manager to take a closer look at this specific card.



  • Thank you for the offer.  I worked around it and now don't have a good example for this scenario.  I will come back to this thread if I run into this issue again.


  • For anyone who finds this article searching for drilling to a different data set, I believe I have an explanation as of 09/19/2017.


    I reread the instructions on how to do drill throughs and tried again. I think here is the reason folks say what they said in the article:


    1. When you click on an item to go to a default drill through to the same data set, you get a Loading icon (see attached)
    2. When you click on an item to drill through to a different data set, you don’t get a loading icon. DOMO is actually doing something but it appears as if there is no data. Especially on large data sets, it looks like there is no data on the drill through. It takes a while before data shows up. In my case, I waited around long enough to see that the drill through actually returned data filtered on the item I clicked.


    I would say in the interim that someone should also change the Domo University article to:

    1. Elaborate more clearly the steps on changing the drill path if you want to point to a different data set.
    2. Put in the expectation that the “Loading” icon is missing (or alternatively fix this in the software)
This discussion has been closed.