Disable Directory Groups

Options
Ashleigh
Ashleigh Coach
edited March 2023 in Scheduled Reports

When we set up SSO we imported all of our Active Directory groups. Well there are way too many of them making it hard to manage groups in general so I would like ot get rid of them. I unchecked the box in SSO that says import Directory groups and remove the passing of directory groups in their actual SSO setup. The groups still show up though. Does anyone know how to remove these? Do I need to turn off SSO and turn it back on?

**If this answer solved your problem be sure to like it and accept it as a solution!

Tagged:

Best Answer

  • TDanis
    TDanis Domo Employee
    Answer ✓
    Options

    @Ashleigh You need to check the box "Show only groups I can manage" before it lets you bulk manage it and have the manage all groups grant ono your security role.

    If I have answered your question, please click "Yes" on my comment option.

Answers

  • TDanis
    TDanis Domo Employee
    Options

    @Ashleigh The Directory groups will need to be deleted within Domo. This can be done in the Admin/groups section and by checking "show only groups I can manage". This will allow you to bulk select I recommend filtering the group type to "Directory". Directory groups will only be imported to Domo if a user is a member of them and logs in through SSO into Domo.

    If I have answered your question, please click "Yes" on my comment option.

  • Ashleigh
    Options

    @TDanis bulk delete does not work for directory groups. It is making me go into each one individually and delete it.

    **If this answer solved your problem be sure to like it and accept it as a solution!

  • TDanis
    TDanis Domo Employee
    Answer ✓
    Options

    @Ashleigh You need to check the box "Show only groups I can manage" before it lets you bulk manage it and have the manage all groups grant ono your security role.

    If I have answered your question, please click "Yes" on my comment option.

  • Ashleigh
    Options

    @TDanis ah gotcha that worked, I am an admin of my system so assumed I did not need to select that.

    **If this answer solved your problem be sure to like it and accept it as a solution!