Domo converts text to date

Options
ggao
ggao Member

I am using salesforce data set to bring data from Salesforce to Domo. I have a text column from Salesforce. The column has value as "2016-03". I want to this to be text, but Domo transform it to a date, 2016-03-01. How can I make Domo to treat it as text intead of date?

Comments

  • kshah008
    kshah008 Contributor
    Options

    Hi all,

     

    Can anybody help @ggao with their question?

    Thanks!

  • andrewnemrow
    andrewnemrow Domo Employee
    Options

    You can use the Magic ETL Dataflow tool to change the column type in your dataset to text. You can access this tool by navigating to Data Center > Dataflows > New Dataflow. Under the Edit Columns section, use the Set Column Type feature.

    Thank you,
    Andrew N.

  • Godiepi
    Options

    Hi ,

     

    the suggestion of doing it through a magic ETL will create an extra dataset. So, keep in mind if is it really worthed doing it that way creating an extra dataset just to modify one column ?

     

    another simple solution would be to do it through a beastmdoe where you can say

     

    YearMonth:

    concat(Year(`DateColumn`),'-',Month(`DateColumn`))

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • kshah008
    kshah008 Contributor
    Options

    @ggao, did any of the above replies help you out?

  • ggao
    ggao Member
    Options

    Thanks, everyone. The replies are really helpful. I think using beast mode is a better approach.