Can not run Quickbooks jobs in Workbench. Access denied.

All my local file and ODBC jobs are working perfectly, but when I try to run Quickbooks jobs in Workbench it fails with the following error message:


"Access to the path 'C:\ProgramData\Domo\Workbench\Pipeline\' is denied."


I have tried running Workbench as administrator, but get the same error. My Windows user does have access to that path (I can navigate there in Windows explorer and make changes). 




  • Have you succesfully run these jobs in the past or is this a new dataset?

    **Make sure to like any users posts that helped you and accept the ones who solved your issue.**
  • They all were working fine, then just stopped one day.

  • @AaronT- Before running your dataset job make sure all the quick book files are closed.hope this fixes the issue.

  • I'm having the exact same problem, what was the solution?

  • SOLVED: Reboot after installation. ?

  • Running into the same issue and unfortunately the two outlined solutions are not working in this case. Has anyone else run into this and if so how did they get around it?

  • For me it just magically started working one day.

  • Hm, let's hope I run into the same thing then! Smiley Happy

  • I'm experiencing this error:

    Access to the path 'C:\ProgramData\Domo\Workbench\Pipeline\' is denied.


    However the subfolder .\Workbench\Pipeline *does not* exist. I am using Windows Authentication and my account *does* have rights to the .accdb file location. I'm using impersonation on the job as well and my test validataion returns "It is unknown if the source data is available in Workbench". 

    My SystemDSN connectinon (32-bit) tests successfully to the file. 

    Chad Bishop
    Data Analyst
    Bolt Express
This discussion has been closed.