Clearing the Queue

We keep getting this error when trying to run datasets. 


[04.12.16 07:39:17] Job could not be added to the queue because it is either already queued or currently executing.


Does anyone know how to clear the queue so we can run them?  THis particular dataset hasn't updated in 16 hours, even though it is set to every hour.  Help.

Best Answer

  • [Deleted User]
    Answer ✓

    Error - Job could not be added to the queue because it is either already queued or currently executing. There are a few reasons why this error can occur:


    1.  Please check that your jobs are not being scheduled too close to each other. If a job is currently running and another job is scheduled to start while the current job is running, you will see this error.  This is normal, as the queue is busy processing the running job. If a job is already in the queue, the queue will not allow it to be queued again until the running job completes, or the Domo Workbench service is restarted.


    2. The current job could be in a non-responsive state.  If a job is running for a longer than expected amount of time, opening a case with Domo Support to investigate the issue further would be the correct course of action.


    3. While recreating a job with a different name, and deleting the job that is stuck in the queue is one way to reset the queue, I would recommend restarting the workbench service.  Restarting the Domo Workbench service will flush the queue.  Normal workflow of workbench jobs should return after restarting the service.  If restarting the service does not return the workbench to normal operation, please open a case with Domo Support.


    I work for Domo.

    **Say "Thanks" by clicking the thumbs up in the post that helped you.

    **Please mark the post that solves your problem as "Accepted Solution"


  • kshah008
    kshah008 Contributor

    Hi all,


    Can anybody help @milesscott with their error?


  • I am getting the same error in the Domo Workbench. It will not run becuase "[04.21.16 11:04:52] Job could not be added to the queue because it is either already queued or currently executing."

  • Getteing same error.. Marcelo Araujo at Southern Insurance Underwirter. Help

  • I end up re-creating the Dataset job with another name and worked. Then I deleted the one giving me the err

  • We are looking into this now with one of our top engineers and will have an update shortly.


    Apology for the delay in getting to this post.




  • kshah008
    kshah008 Contributor

    @maraujo  @RussellRezekLIS @milesscott


    Did regularWBGuy's reply help wiht the error?

  • It did for me. I restarted the Workbench and changed the schedule to avoid colliding with any other jobs and it seems to be working fine now.

This discussion has been closed.