Workbench Replacement Variable not saving

I've created a handful of Workbench jobs over the past few months, but every time I do, I seem to have to struggle for about an hour each time to get the replacement variables working with the 'Append' update method. This typically includes trying every imaginable order of operations, deleting and recreating the job multiple times, etc. until I finally stumble upon some way of making it work. I even went so far as to write down the exact steps I took last time I was able to successfully get it to work, but it's not working for me this time. Below are the steps I'm taking and a sample of the query I'm using.

  1. Create the job
  2. Set update method: Replace
  3. Create the replacement variable (TransactionID)
  4. Leaving the replacement variable out of the WHERE clause of the query, close and save
  5. Run the job
  6. Change the update method to 'Append'
  7. Check the replacement variable (This is where it's currently failing; replacement variable doesn't exist)
  8. Add the replacement variable into the WHERE clause of the query
  9. Save and run the job

Of course, since the TransactionID replacement variable doesn't stick, running the job again on step 9 fails. I could really use some help if anyone has any ideas.


Best Answer

  • GrantSmith
    GrantSmith Coach
    Answer ✓

    I’ve gotten some success updating to the latest version of workbench and also pressing enter when I enter a value for my replacement variable. This will show an empty row but have found that typically will save the variable

    **Was this post helpful? Click Agree or Like below**
    **Did this solve your problem? Accept it as a solution!**


  • It seems that updating to the latest version has solved the issue (Workbench 5.1 from version 5). My fault for not checking this; I knew that I had automatic updates enabled and therefore assumed I had the latest.

    It's still not behaving exactly how I assume it should, but it is workable now. It seems I have to run the original 'Replace' set first with the replacement variable, then I'm able to go back in and manually set the value of the replacement variable. After the first 'Append' run after manually setting the value, it then picks it up and automatically updates the value.