Row size is wider than MySql supports. Please reduce the row size or number of columns.

OK so I have this one dataflow, DataFlow A, that feeds into other dataflows, DataFlow B and DataFlow C, that works perfectly fine until I try and add this one additional column to it called Lead Source.  When I add this column to DataFlow A it runs just fine, however, DataFlow B and C then fail due to this reason: "Row size is wider than MySql supports. Please reduce the row size or number of columns."

In DataFlow A, I have tried the following but neither have worked:

        1) CAST(a.`LeadSource` as CHAR(1000)) as LeadSource

        2) ALTER TABLE `agreements2` MODIFY COLUMN `LeadSource` VARCHAR(100)


Then when trying to edit DataFlow B and C, I can't even load the table to remove the column since its not needed for those dataflows.

Is there something else I can try?  Please help!

Best Answer

  • cwolman
    Answer ✓

    I have run into this issue in mySQL dataflows and my workaround was to run the table through an ETL dataflow first as that does not appear to have a column limit.  The ETL would exclude any extra columns not required.



  • Thanks.  I just created a copy of the same dataflow and removed the one column.  I fed this new dataflow into the other dataflows and all seems to be working correctly now.  Thanks for the idea!  Just wish there was another fix instead of created an additioanl dataflow.

  • WHM
    WHM Contributor

    I had one and flipped it to RedShift. There was a regex expression (probably why it was not redshift to begin with) so I had to convert that to redshift syntax. to me, much easier that "re-writing" in magic ETL...