Date Output Format Not Working



I'm building time series cards with the x-axis displaying by week.  Unfortunately this displays x-axis information in a 'Week-## yyyy' format, which is difficult to interpret as it isn't immediately clear what particular month a specific week belongs to.  For example, 'Week-33 2015' doesn't jump out to me as belonging to August.


I'd like to convert to an easier to interpret format, something like MM/dd/yyyy, and I see an option to modify this under 'Date Output Format' within 'Category Scale (X)', but this doesn't seem to be working for me (it doesn't change the x-axis format).


Is there something I'm missing?  I've made sure to select the 'Never Use Time Scale' option as the 'Date Output Format' option says to do.


Any help is appreciated.

Best Answers

  • Godzilla
    Godzilla Contributor
    Answer ✓

    @swyatt if he uses 'Business Date' in the Date range and 'Week Ending date' on the x-axis, he would have to set the group by to 'None' in the time grain up top in order for the date format not to change along the x-axis to the 'Week #, yyyy' format.

    However, when you set the group by to 'None', it ends up taking away the Group By field for the end users so they will not be able to change the aggregation to monthly.


    What i've done before is create 2 charts in this scenario, one chart being strictly a weekly view (group by set to None) and the second chart set to daily (group by  set to day) which allows the users to change the aggregation. 

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • Unknown
    Answer ✓

    There is a solution available.  If you navigate to your Company Settings under the Admin section, you'll see an option to control the week date display.  It can either be in the week numbers or week date format, so Week-3 vs 1/21/16.

  • Yep, all set. Saving the wrong settings, then reverting and saving it the way we wanted seemed to do the trick.


  • Godzilla
    Godzilla Contributor

    Once you change the time grain on the top to group by week, it automatically converts back to the  'Week-## yyyy' format. 

    You will have to add the week start/end date to your dataset to be able to show it in a more friendly format. However, just as a heads up, when you do this, when your users change the time grain to monthly, the aggregation will not be correct. 

    Domo Arigato!

    **Say 'Thanks' by clicking the thumbs up in the post that helped you.
    **Please mark the post that solves your problem as 'Accepted Solution'
  • swyatt
    swyatt Member



    Do you know if the aggregation would still be incorrect if he used the `Business Date` in the Date Range Field and still placed `Week Ending` on the X-Axis?



    That way when the end user changes the aggregation to monthly it will only reference the business date and not the category scale.

  • swyatt
    swyatt Member

    Makes since to me. I appreciate the clarification!

  • RobynLinden
    RobynLinden Contributor

    Just want to tack on here to say that I think in general Date functionality needs improvement in Domo. I put an idea in the idea center, would be great if Domo staff could please review. 


    I think this thread is very informative for card builders, and I will review it to make sure I understand the details here -- but in addition to needing more information for builders, I think the way dates are displayed to users (below) is confusing and needs clarification and some refinement. You'll see more in the Idea section. 



    unexplained date.PNG

    Broadway + Data
  • nalbright
    nalbright Contributor

    I agree; I know I've had to explain to other users the reason why some dates look as they do.

    "When I have money, I buy books. When I have no money, I buy food." - Erasmus of Rotterdam
  • Is this still the solution offered or does anyone know if Domo has rolled out any functionality allowing to display weekend dates rather than the number of the week? 

  • Thank you @trawayMMC, is this option working for you? I made the changes earlier but it did not affect any of the charts. Maybe I should open a ticket with support.



  • @trawayMMC I just undid the setting and re set it. It's now working, thank you for the help!

  • Yup, I had the exact same problem :).  Resetting also worked for me.

  • Theoretically, that's a great solution. However, it doesn't seem to work...


    Edit: Just saw the posts about changing it to the wrong setting and back... Need to try that workaround.

  • @josh_schlag, please let us know if that worked for you.




  • Yup, that saved my day! Super usefull thread!!

  • This worked for us too! Thanks!

This discussion has been closed.