403 error connecting to domo.com


I have been getting 'Error Processing Domo Request "api/data/v1/onboard/agents": The remote server returned an error: (403) Forbidden.' error everytime I connect to domo server on my workbench on my desktop.


It works perfectly on my laptop indicating that my windows firewall/or other settings has gone rogue. Has anyone faced this issue? IT says reimaging is the only option and I don't want to do that :(


Any help would be appreciated.


Best Answer

  • domo_ooed
    Answer ✓

    So we figured this out with help from DOMO. Here is what happened. There were some jobs which were stuck (not showing on my workbench nor on my dashboard on <>.domo.com.

    I was given admin rights and was able to remove these jobs. Once done, I was reverted back to previous role and work bench started working again.


    So incase you get this error out of the blue, reach out to DOMO admins to promote you as admin and delete any jobs that are stuck !


    Thanks all for responding.


  • jeremyhurren
    jeremyhurren Domo Employee

    A 403 Forbidden error generally means just that. For whatever reason, the credentials workbench is using to connect to Domo do not have access to get the list of agents on your Domo instance. I would re-configure the Domo account that Workbench is connecting with. Maybe generate a new Api token for it to use.

  • kshah008
    kshah008 Contributor


    @domo_ooed, did jeremyhurren's reply help you out?


  • Not really, it works on my laptop and not on my desktop.

    I am assuming it has something to do with my windows settings on my desktop. 


    if it is an api token issue then my credentials shouldn't work on any system right?

  • MrMiyagi
    MrMiyagi Domo Employee

    Hi Domo_ooed,


    Privileged users should be able upload files - I just tested it and it worked for me.  Would you mind logging out and logging back in to Workbench? I am wondering if it just needs a refresh of your credientials.


    If that does not work please take a look at the log file for the failing upload. You can find the log file by clicking on More -> View Logs -> and then search for the log file with the name of your data set. Often times you will get better information about the error in the log file to help us troubleshoot. Share the log file if you would.


    I hope this helps!








  • I don't know if this will be applicable to you and what's causing you to encounter this error, but I have run into this issue before. In my case, what happens is that internally, we make use of virtual machines with Workbench installed on it. When we copy a VM with the standard configuration and don't make any changes, it will throw the (403) Forbidden error when trying to make Workbench connections. The workarounds for us in this particular case are to either 1) be made an administrator in the Domo instance or 2) change the Windows computer name of the VM.

    ** I work for Domo
  • kshah008
    kshah008 Contributor

    @domo_ooed, did any of the last two replies help you out?

This discussion has been closed.